Taurus Firearm Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
went to the range yesterday with my PT1911...25 degrees with slight wind,cool to say the least.....

tried my reloads with 230 gr LS HP with 5gr 700X,cci LP primers...
at 20 yards first round in the black,second cut the first rounds hole,third round got thrown to a 1.5" 3 shot group....now this is when the SHTF....fourth round was fired and i felt hot tingles hit my right cheek,like small welding spatter(i wear prescription glasses,so im blessed with safety glasses every day)....so,i check the brass and they had black soot on the half that faced up in the chamber...chalked it up to the powder being dirty burning....fifth round i fired was fine and still a little dirty....then sixth round i fired,locked the slide tight with the fired brass in the extractor and the slide locked approx.1/4" back and i mean locked....both hands on the slide(with mag out,not loaded)would not give it up....handloads showed no signs of pressure,no bulged primers and primers all in the pockets....no excessive recoil,recoil was mild....just soot on the outside...

im a tinkerer at heart,and built many rifles from scratch....so,i got it in my head that its not going back to Taurus...pulled the hammer back(not loaded) and held it with the muzzle up in my hand and rapped it on a wood table till the slide went forward into battery....worked the slide and the brass ejected fine....i chalked it up to my reloads and chucked the rest in the woods as far as i could throw them....

i tried some factory loads(AE 230 FMJ),them cycled fine,for 5 rounds then did the same thing but nowhere as hard,heres the kicker,when i went to pull the mag out,it stuck slightly in the magwell,little harder pull and the follower in the mag pulled out of the inside of the mag(never seen a magazine do this before)i know the magazines are a little shady,but holy cow they are fragile....little tap on the table and the slide let loose(unloaded)...after that time i was getting a little PO....loaded a full mag and gave it to her as fast as i could pull the trigger,it was all good...but had no more ammo to see if it would keep doing the problem....

mind you that this WILL not go back to Taurus,if it keeps it up i will build it as its such a great platform...

so my pretty 1911,isnt so pretty anymore...but,really dont give a poop....overall im impressed with the accuracy,trigger is absolutely awesome.grips suck,sights are a PIA but i can get used to them....

so can you fine people give me some incite on whats going on?i checked the internals with a normal field strip at the range and when i got home,little dirty but no broken parts or bent or bulged barrel....so to say the least im stumped!

sorry,its a long post,but tried to explain things going on in my eyes.....
 

·
TaurusArmed.net Forum Founder
Joined
·
6,541 Posts
I was about to ask you if you found anything, but then I read the last of your post. It seems like you know something about guns and don't mind finding out for yourself what is going on.

Are there any gaulded looking spots on the frame/slide where they meet? What about the disconnector? What does the firing pin block in the frame that comes up to release the block look like? I could see that getting in the way.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
pics coming


everything looks good so far...just dirty as i left it alone after the beating it took....only have one pic that is a ????
 

·
Registered
Joined
·
61 Posts
Discussion Starter #4
this is whats in question.....is the ramp supposed to have these slices in it?

http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1010.jpg
and the recoil rod has a funny light gouge in it...
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1018.jpg
one other spot on the recoil rod is in question,the pin set mark on the plunger end....
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1017.jpg


the rest....

mostly machining marks is all i see....and wear from being worked
sorry i didnt clean it before hand....but wanted to leave it as is....frame:
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1006.jpg
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1007.jpg
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1011.jpg
slide:
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1012.jpg
barrel
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1014.jpg
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1015.jpg
looks the same on the other side....
inside the slide...
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1022.jpg
 

·
Super Moderator
Joined
·
21,609 Posts
field stripped mine right away and took some pics this shows polished feed ramp with no marks

[attachment deleted by admin]
 

·
Registered
Joined
·
61 Posts
Discussion Starter #6
thank you sir!

i think i will do a little grinding and polishing with the ol'dremel now....that would be the culprit i think....what would you suggest for a fix?
 

·
Super Moderator
Joined
·
21,609 Posts
there are machine marks on the frame and there was no pin in the guide rod or marks hope this helps

[attachment deleted by admin]
 

·
Super Moderator
Joined
·
21,609 Posts
Looks like they skipped a stage in there finising I'm not a gunsmith but do dabble a little. your intiteled to a good gun out of the box I know we love to twink them or we would not have bought a 45 but missing a major step i'd send it back I know thats the last thing anyone wants to here but its up to you let us know how it turns out its a great gun and can out shoot far more expensive guns
 

·
Registered
Joined
·
61 Posts
Discussion Starter #9
the guide rod will be fine i think,if not thats a easy part to find...the only part that has me a little iffy is the marks in the ramp...should i dremel them out?or just file them smooth?
 

·
TaurusArmed.net Forum Founder
Joined
·
6,541 Posts
I think this pic here holds something too.



The little shinny thing just above the disconnector, not sure what you call it, but I think that might be coming up and making the slide hang. Mine looks blued still. I only have 200 rounds through it though.
 

·
Super Moderator
Joined
·
21,609 Posts
I'm camparing mine to yours right know mine is about 1/16 or a little less below the frame and is also silver in color if you click on my pics they will blow up so you can see things real clear
 

·
Super Moderator
Joined
·
21,609 Posts
also notice when you blow up my first pic it will show some light filing on the frame just on the edges this could cause some binding if yours is a little tight
 

·
Registered
Joined
·
61 Posts
Discussion Starter #14
Flyer said:
I think this pic here holds something too.



The little shinny thing just above the disconnector, not sure what you call it, but I think that might be coming up and making the slide hang. Mine looks blued still. I only have 200 rounds through it though.
i have 108 threw mine right now....

heres my polishing of the ramp....be honest on what you guys think....put a loaded mag in with no slide,and takes little effort to make the bullets shoot out of the mag.....seems to glide on the polished ramp now...
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1024.jpg
http://i13.photobucket.com/albums/a283/CBRSCOTT/IMG_1023.jpg
 

·
Super Moderator
Joined
·
21,609 Posts
I've got mine apart and took a pen and from the front the shiny piece moves freely up and down
 

·
Registered
Joined
·
61 Posts
Discussion Starter #17
ok,thanks.....but,it does have some wear on it and does look to be alot of scratch's on the slide where that rides,so its got me wondering....is that part oversized?could it be lightly polished?
 

·
Super Moderator
Joined
·
21,609 Posts
Don't know there are some really good guys on here that I noticed are'nt signed in right now might want to wait and see if you get more replies good luck
 

·
Super Moderator
Joined
·
21,609 Posts
Thats what were here for :) These guys have saved me I don't know how many times its a great forum and I'm sure you'll enjoy it hope you have a great day. A pic of my baby

[attachment deleted by admin]
 
1 - 20 of 31 Posts
Top