Taurus Firearm Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi everyone......Just picked up a couple of 738's today...stainless over pink for the wife and black stainless for myself. Well the wifes performed good but my trigger is malfunctioning..won't catch every time (pull the trigger and nothing-not engaging the hammer). It's going to full battery and i'm letting the trigger reset so I know it's not me.

On an empty mag it seems to work every time?? First thing I did was take them apart and thorughly clean them (both 738's). The mags on mine looked like they were used?? I know i've got to send it back to Taurus but anyone have any ideas. Tried one of the wifes mags and fired twice then nothing....Thanks, Dave
 

·
Registered
Joined
·
85 Posts
I have to ask what might seem like a silly question, but when you say you "reset" the trigger did you partially release it until you felt a "click" in the trigger or did you let it go all the way back to the static position? If you stage the trigger you won't get full hammer draw an have light or no primer strikes. It has to do with how the 738 has a partially preloaded DAO trigger and not fully releasing the trigger will cause the trigger to not start the operation from the proper position to fully engage/charge the hammer.

I hope its just a simple issue with your 738.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Not a silly question RSC....I just pull the trigger and nothing happens or it might fire once and then no more trigger. I can take the mag out and the triggers acts normal.??
 

·
Registered
Joined
·
535 Posts
Might help you. Might not. There's a lot of little things he did to get a "silky smooth" trigger.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Unfortunatley I have no trigger at all..when you pull it, it does nothing. Best way to describe it I guess would be like no brakes on a car LOL!
 

·
Member Emeritus 1946-2018
Joined
·
35,996 Posts
I'd contact Taurus customer service about this issue.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Yeah, looks like it's got to go back for sure MilPro...Tried to trade the wife out of her stainless over pink but she wouldn't trade he he!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9
Fed X picked it up yesterday and the guy at Taurus thought it would be there for about 2 weeks....which probably means a month in taurus time..lol!
 

·
Registered
Joined
·
6,559 Posts
When I sent mine back, it only took 10 days back to my door. I got the gun the back the same day I got an email saying they received it and were expecting two week turnaround. You should get it back quickly.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #12
Well guys...I got it back today and it functions flawlessly...eats anything I put in it and I have full confidence in this 738. I asked them to replace the 2 mags that came with it and they did. One of the mags that came with it was so bad that a gorilla would have a hard time racking the slide with that mag in it. Thanks for all the help and suggestions...Dave
 

·
Registered
Joined
·
3 Posts
I was beginning to think that I was the only one that had the same problem you described. I had mine for about 8 months without using it much, then shot about 300-400 rounds through it over a short period. Then one day at the range it would randomly fire every other trigger pull, then not at all. If I racked the slide it would half cock it and at the end of the trigger pull it would release the half cocked hammer, but the trigger wouldn't pull the hammer back on it's own. I just sent my TCP back on Tuesday (2-21-12). I hope I have the same luck as you do when I get it back from Taurus.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #14
Welcome to the boards Soundcheck....You had already fired 3-400 rounds when this happened....Mine was that way right out of the box but they did get it back to me in about 8-9 days. They wrote on the paperwork "Trigger will not engage hammer" (the problem) and then wrote "Adjusted" (the solution).

I have fired about 70 rounds through it since with no problems but who really knows what waits down the road...Keep us posted on your outcome.
 

·
Registered
Joined
·
3 Posts
It took the full six weeks to get it back from Taurus. Haven't shot it since, but the hammer was pulled back by the trigger when I got it back, so I assumed the problem was fixed.
 

·
Registered
Joined
·
5,072 Posts
Soundcheck863, go shoot the gun and let us know. It sucks when your gun won't work!
 
1 - 16 of 16 Posts
Top