Taurus Firearm Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter · #1 ·
My PT111 Mil-pro (3rd gen) will not allow me to rack the slide. A round is chambered and I don't know what to do. Earlier on it did the same thing with an empty chamber. I had to pull the trigger and it released the slide. I may have to wait until I get to the range in order to shoot out the round, Is this a bad idea? I removed the magazine and tried again, but it remains locked. What could be the cause of this all of a sudden?

Mike
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #3 ·
The safety was/is not engaged. I was having problems engaging the safety after racking the slide. If I wiggled the trigger just a wee bit, it would allow the safety lever to engage (I did hear a slight click when I did this). This however, isn't a very safe practice. If I can't resolve this issue at the range, I will have to call Taurus CS. I may have a problem shipping a loaded gun to them. I'll see what will happen tomorrow.
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #6 ·
DRAEGER said:
I read once some place that the internal lock screwed up and engaged. I know its a long shot but maybe try your gunlock key and see if something is mucking up on that end.
BINGO!!! give that man a cigar.
I took the 111 out to the range today and did just what you said (before I read the post, go figure). Afterwards, the slide racked and after 100 rounds shot through it. I am happy to report that my mil-pro is back in business.

Thanks for the input guys.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top