Taurus Firearm Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Ok guys before I hit up taurus customer service I figured I'd ask around to see what y'all thought here. With my pt 740, I have an issue with the gun that when I shoot off the last round in the mag sometimes the slide will not lock back and when this happens its also more difficult to eject the mag. The mag seems to be jammed in the gun. I can still remove it just with a little force.
I've found that this only happens when I lock the slide back manually, load the mag, and then hit the slide release loading a round.
If I load a mag then pull the slide back and chamber a round that way it does fine...
really wierd issue but I figured someone might have an idea. Thanks for the help!
 

·
Registered
Joined
·
206 Posts
If I load a mag then pull the slide back and chamber a round that way it does fine...

I'm sorry I can't help you with the issue , I'm sure someone will be along to help soon though. What i can tell you is if your manually putting a round into chamber then releasing slide you can damage your weapon. ONLY load rounds through the magazine.

Edit: I can see i need to learn to read .... sorry :p
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
Lol. No problem. Yeah it's definitely through the mag.
I also though you guys should know that toy knowledge the gun probably has done this since new. It's got about 200 rounds through it. Been cleaned as thorough as possible two or three times.
 

·
Registered
Joined
·
27 Posts
I have had that happen to me with a S&W 6946 not a Taurus. I found that I was touching the slide release just enough to deep the slide from staying back on the last round. I don't know if this is the problem but I just wanted to share.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
I'm curious, did your mag kinda stick as well? Still easy to eject with some force but definitely only happens when the slide doesn't lock back after the last round is fired.
 

·
Registered
Joined
·
443 Posts
On the PT111 the mag follower once empty pushes up on the slide lock. If you lock back the slide with and empty mag you can check to see if it is.
 

·
Registered
Joined
·
15 Posts
Does it do it with both mags? I had a bad mag and it would do that as well as double feeds and failure to feeds,a new mag no probs. Good luck
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #9 ·
It has done it with both mags. I actually worked on it yesterday and fired some rounds through it. Went pretty well. I bent the little piece that hits the orange piece on the mag once its empty. I bent it about 1/32 of an inch downward. Helped push the slide lock upwards. We'll put a couple hundred more rounds through it and see how it does...
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #10 ·
Allllrighty so I actually worked on it worked on it and worked on it and narrowed it down to one mag. I just kept getting them mixed up at first. It looks like the black catch on the orange peice in the mag, isn't quite catching on the slide lock tab upon firing the last round. Doesn't lock the slide back and doesn't quite release the mag. I believe this is partially due to the spring being slightly bent at an uneven angle and partially due to a poorly developed orange piece lol. I'll send it in for repairs and in the meantime buy me a third mag to use as a spare. A great excuse to buy another one lol.
 

Attachments

·
Registered
Joined
·
2 Posts
Put a small dab of silicone caulk on the top of the magazine follower, where it catches the slide stop. It's not pushing it up and enough to catch the slide well. May have to reapply every so often.

Sent from my SAMSUNG-SM-G890A using Tapatalk

Sent from my SAMSUNG-SM-G890A using Tapatalk
 

·
Registered
Joined
·
37,067 Posts
Put a small dab of silicone caulk on the top of the magazine follower, where it catches the slide stop. It's not pushing it up and enough to catch the slide well. May have to reapply every so often.

Sent from my SAMSUNG-SM-G890A using Tapatalk

Sent from my SAMSUNG-SM-G890A using Tapatalk
Welcome to the Forum!
and congratulations for answering the oldest post in existence on the forum!
4 plus years.
heres a little something for you.----:sport20:
we allow new members to participate in current post by the way!----:image001:
 
  • Like
Reactions: CWB

·
Registered
Joined
·
2 Posts
Welcome to the Forum!
and congratulations for answering the oldest post in existence on the forum!
4 plus years.
heres a little something for you.----:sport20:
we allow new members to participate in current post by the way!----:image001:
Awesome!


Sent from my SAMSUNG-SM-G890A using Tapatalk
 
1 - 13 of 13 Posts
Top