Taurus Firearm Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
I have two pt 1911's, the first one breaks down and reassembles just fine, the new one when trying to assemble it, the slide stop doesn't go it all the way to fit flush, i feel where it wants to go in and it does go in a little bit but not all the way to sit flush, if I just put it in and let it hang down towards the trigger guard it goes all the way in but trying to rotate it around to where it meets the notch in the slide, it won't go in all the way like something is stopping it but trying to lube the area and trying a rubber mallet lightly, nothing is making it go back in! I tried seeing what would happen if i left it how it was but with an empty mag the slide won't lock back so obviously it needs to go in all the way but I don't know what else to try.
 

·
Registered
Joined
·
373 Posts
Try using a thin blade knife to push the little slide lock plunger in while up push the slide lock in place. Be easy or you will put an "idiot" mark on your gun.
 

·
Registered
Joined
·
15,372 Posts
If it's a new PT1911, the plunger that FZ1 mentioned could be filled with that protectant crap and will not slide in the tube nicely.
 

·
Registered
Joined
·
9,208 Posts
get whatever your normal cleaner of choice is into the hole, a small cleaning brush (nylon not wire) for say a .22 or .17 caliber; and some compressed air to blow out the channel if you can't wedge a piece of a cleaning patch through with a paperclip. If that doesn't work, I would check the slide stop itself to make sure there are no burs on it that would make it hangup going through there like it should.
 

·
Registered
Joined
·
11 Posts
it's such a little piece, how would I go about trying to clean it out?
I used a tooth pick (Sharp tip broke off) with a cut piece of patch to clean out the plunger tube. Just be careful not to accidentally tear a hole in it while pushing it through. FWIW...
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #7 ·
the pin will go all the way in when i use a coin or allen wrench to push on it but when I try to insert the slide stop, it'll click but only go halfway, i tried cleaning it with a toothpick and cloth the best i could.
 

·
Registered
Joined
·
11 Posts
I would check the slide stop itself to make sure there are no burs on it that would make it hangup going through there like it should.
I'm no expert as I've only had my pt1911 for a mouth and a half, but I would have to agree with Montkun on this one.
 

·
Registered
Joined
·
37,079 Posts
sounds to me that you don't have the take down notch lined up properly.
IF the notch isn't in the proper alignment then it won't go in.
I do mine actually by feel , not by looking at it as many are slightly different where they line up, it just drops in like a suction on it once its lined up, if not no amount of pushing is gonna let it slip in.
Just my idea.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #10 ·
yeah i know where it needs to go in and it will start to go in and make a kind of click sound but the pin on the right side of it prevents it from going in fully
 
1 - 10 of 10 Posts
Top