Taurus Firearm Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
:( well after fixing my g2 and testing it , it ran flawless the other day. Well went to the range again today to work on my techniques I get "click". Tried pulling the trigger a few more times and nothing. Ok bad primer.... bang bang... click. Ok another bad round. Again and again. Pulled out a different box of ammo different brand and same thing. Then I knew somthing wasn't right. Looked at the primers and the firing pin hit but barely. Had a buddy with and loaded up 10 rounds that mine didn't fire cause of light hits and shot all them. Thinking about sending it in. Had a few problems with the gun and I'm not comfortable yet with reliability as a ccarry gun. Love the gun but seems like problems are coming up every other time I goto the range. :icon_ cry::icon_ cry:
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #3 ·
Well I took the firing pin out and cleaned it and the channel/grooves real good and went to the range. Click click bang.... same thing. althoug this time I pulled the trigger and somtimes it didn't even click. the trigger pulled back with no click or tension. Sounds like it's not catching or somthing. Time for it to go for a road trip to Taurus. :(
 

·
Banned
Joined
·
17,333 Posts
It's mechanical and things happen, I'm sure Taurus will take great care of your pistol.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top