Taurus Firearm Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a band new PT145 in stainless that I picked up from Davidsons...love it, although the trigger pull is very strange...it is very long in SA mode, but the first 3/4 of the travel has no resistance, then a little resistance and then it fires...is this normal? It seems that the first 3/4 of the long travel is pointless, as the trigger feels like it is literally just moving with no spring resistance...
 

·
Registered
Joined
·
522 Posts
.
 

·
Administrator
Joined
·
40,396 Posts
Perfectly normal. In time you will learn where the trigger resets after each shot. Then you won't be allowing the trigger to return fully forward hence avoiding the extra travel. If a misfire should ever occur, then the pistol will revert to double action and you will use all of the trigger pull and you will feel resistance.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Ok...now I understand...I'm sure I will get used to it, it is a very nice gun, and am still amazed that such nice fit and finish, along with 10 rounds of 45 come in such a small and managable package!
 

·
Registered
Joined
·
509 Posts
Yeah, it takes a little getting "use to".
I lightly polished the "Block" for the striker with a little dremel buffing wheel and some MILD metal polish.
It smoothed out that little hitch I felt before the striker block was released.
I DO NOT RECOMMEND YOU DO THIS YOURSELF UNLESS YOU KNOW WHAT YOU ARE DOING and take TIME while doing it!
 
1 - 5 of 5 Posts
Top