Taurus Firearm Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
Well, I have had my MilPro for almost a year now and have not had one problem ever until 5 rounds into shooting it today. I was shooting Winchester Ranger 155gr JHPs, not a +p round. After the 5th round fired, the recoil spring and plug went through the front of the slide. Now it did not fly all the way out but was stuck in the middle of the larger spring on the slide. I can not get it to push all the way through, one way of the other. I have a feeling the plug had been worn down somehow and it pushed through the end of the slide or the slide had a peening issue. I have shot about 600 rounds so far with it.
Has anyone else had this problem? How did you fix it? Have to send it back to Taurus (which I dread doing since their CS dept is terrible from the sounds of it)?
Any advice is greatly appreciated.
Thanks.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #2
Well after researching this QC malfunction I had I see it is not uncommon. This is totally unacceptable.
I did call Taurus CS and they said to send the recoil spring assembly tothem and they would send me a new one. Well, I can't get the damn thing out of the slide. It appears that after coming through the slide the front of the spring decided to open up a bit and after a couple hours of trying to get it back through the slide I have given up. The CS rep said she couldn't send a new one without getting the old one first (they do have them in stock now), which in a way I don't blame her but c'mon, all this hassle for a $3 part?
I have been loyal to Taurus for 15 years seldom straying but this makes me sick. They should just send me the new assembly and I'll cut the old one out instead of having to send my slide tothe monly for them to either lose it or not get to it for 3 months.
Oh well. We'll see if they actually do a loyal customer proud or if they lose the business forever
 
1 - 2 of 2 Posts
Top