Taurus Firearm Forum banner

1 - 12 of 12 Posts

Registered
Joined
796 Posts
Discussion Starter #1
I am having issues with my PT-145 loading hollowpoints. If I have more than 8 in the Mag it will not load the first round 98% of the time. I noticed when I put round 9 and 10 in the front of the round is at a much higher angle. I was wondering if anyone knows how to correct this. Taurus had no idea but did offer to replace the mags for free. Since it is happening with both mags I doubt that will help. Any suggestions? I have already tried stretching the front of the springs on one mag but that did not help at all.
 

Administrator
Joined
39,896 Posts
Before I tinkered with anything else, I think I would try the free mags.
 

Registered
Joined
796 Posts
Discussion Starter #3
I think I will try that. They told me to send them in. I have to pay shipping but that is pretty much standard with any warranty. I just doubt it is going to be any different. Other than this issue I love the PT-145. Might have to exchange it for a different PT-145
 

Registered
Joined
876 Posts
Once you get the first round loaded, do they all feed when you pull the trigger?
 

Registered
Joined
796 Posts
Discussion Starter #5
They did last time firing but it was loading the first round fine last time firing too. So I am not sure. Also on the 2% of the time it loads the first round the second does not want to load either. I just went and bought some better ammo. Federal Hydrashok. That will hopefully fix the issue. They seem to be a bit longer than the PMC that I have in there now. Will see in about 4 hours.
 

Registered
Joined
59 Posts
I think I am sort of having the same issue with my mil pro pt140, where the 1st one doesnt want to load fully, and I'm having to smack the back of the slide to get it to fully engage.
I've talked to a few (smith) guys and they have said "put a few more rounds through it and it will clear up". So, I'm going to change ammo brands, put a few more rounds through it and see what happens.
 

Registered
Joined
796 Posts
Discussion Starter #7
Just an update. They Federal Hydrashok works beautifully. Not an issue at all. Seems to just be the PMC.
 

Registered
Joined
153 Posts
I had the same problem until i purchased Corbon 185 grain hollow points. They load and feed fine. I am finding that my PT145 is a bit sensitive to the ammo I use.... doesn't like the cheap stuff.
 

Registered
Joined
91 Posts
seems your PT 145 is more sensitive to OAL of a cartridge then others are. NOT a serious problem. especially when you have a good cartridge now.
 

Registered
Joined
796 Posts
Discussion Starter #12
Bezoar said:
seems your PT 145 is more sensitive to OAL of a cartridge then others are. NOT a serious problem. especially when you have a good cartridge now.
Those are the only rounds I had an issue with. Every other one has worked. Blazer brass, Blazer alum. and steel casings. It will eat them.
 
1 - 12 of 12 Posts
Top