Taurus Firearm Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Got a new Taurus 66 last week and had a few questions.

My first issue is that when I took it out to shoot for the first time I had to dial the rear sight all the way over to the right to get it shooting where I was pointing. There is literally only one click left before it gets to the far right end. Is this something I should be concerned about?

The second issue was the second time I took it out I noticed the lug under the barrel doesn't match up to the frame. Here's a pic:



Is that something I should be worried about? I did not notice this the first time out. But couldn't swear it wasn't like that either.

Thanks for any help
 

·
Registered
Joined
·
29 Posts
I had to send my new 6" 66 back for the same issue with the POA vs POI- mine shot WAY left and I couldn't move the rear sight enough to correct.
Got it back in about two weeks fixed.
 

·
Banned
Joined
·
15,276 Posts
cat hello 3.jpg From Northeast Florida!


I recommend you see about sending it back to Taurus and let them fix the problems. I is better to be safe than sorry.
 
  • Like
Reactions: criderrc

·
Registered
Joined
·
4,765 Posts
Hello and welcome to the site! That underlug does not look right. There should not be a gap there.
 

·
Registered
Joined
·
7,787 Posts
Welcome to the forum from Northern Oklahoma.
 

·
Registered
Joined
·
5,922 Posts
Welcome from North Carolina. Sounds like your gun is jacked up. Barrel is either bent or cross threaded into the main body. Explains why your sight is way off too
 

·
Registered
Joined
·
12,088 Posts

Welcome to the forum and the Taurus family from NJ !

New Jersey.jpg
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Well that's disappointing.

Thanks for the welcome though.

It is currently shooting to point of aim. So maybe I'll just put a few more rounds through it and see what happens.
 
1 - 9 of 9 Posts
Top