Taurus Firearm Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2,554 Posts
Discussion Starter · #1 ·
I posted this in the 700's forum without much input, maybe you guys can help

Ok guys, I've had this gun apart many times for cleaning.*I gave it a cleaning this morning and put it back together, now DA does not function??

*Trigger just free travels and the safety trigger don't seem to pop fully into place??
*If I slide the slide back just a hair, it engages?
You can hear a click and then safety trigger pops back

What I do wrong?
 

·
Registered
Joined
·
2,554 Posts
Discussion Starter · #2 ·
Nothing?

Looking at the lines on gun and looking at the rear, it looks like the slide is traveling too far forward, by just a hair but it seems to be enough to keep the trigger from engaging in DA mode.
SA works fine.
 

·
Premium Member
Joined
·
14,139 Posts
I don't have that gun so all I can do is give you a bump. Hopefully someone with experience with the 709 will come along soon.
 

·
Registered
Joined
·
2,554 Posts
Discussion Starter · #4 ·
I don't have that gun so all I can do is give you a bump. Hopefully someone with experience with the 709 will come along soon.
Thx, I called Taurus CS lastnight and after being on hold 3hrs, my little 709 is taking a trip to Miami :(
I'm fairly certain it's in the recoil spring. It don't seem to fit as snug as it did before, and sometimes it binds and won't compress enough to reinstall..
Kinda disheartening I just bought it new on 2/9. The front sight is stripped and I've had some fail to feed issues due a bad magazine also. Hopefully it will be returned quickly. I got this for EDC but the trust isn't there yet.
 

·
Premium Member
Joined
·
14,139 Posts
Since you had multiple problems, you deciding to send it to Taurus is the best move. I hope to hear of the repair results when you get it back! :)
 
1 - 5 of 5 Posts
Top