Taurus Firearm Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My slide is jammed after tring to disassemble for the first time on my pt 140 millennium. Need some advise please.Thanks
 

·
Registered
Joined
·
6,559 Posts
Try pushing the trigger forward to reset it so to speak. I did the same thing the first time. Push the trigger forward and see if the slide will move backwards a little. Then pull the trigger again and pull the slide off.
 

·
Registered
Joined
·
250 Posts
You're not the first person to do that with a milpro. You haven't hurt anything and practice makes perfect.
 

·
Super Moderator
Joined
·
38,045 Posts
Welcome aboard from Northern Illinois and congrats on the new gun.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Try pushing the trigger forward to reset it so to speak. I did the same thing the first time. Push the trigger forward and see if the slide will move backwards a little. Then pull the trigger again and pull the slide off.
Thanks for the advise I will give it a try.
 

·
Registered
Joined
·
14 Posts
I called Taurus, fl they told me to push the trigger(trigger was all the way back during this) with force to the front, i did this and it loosened up ok to disassemble now.
sure saved me having to
 

·
Registered
Joined
·
1,706 Posts
Yeap, gotta pull the trigger while zliding the slide to the front. It will disenguage the locking mechanism
 

·
Registered
Joined
·
10,732 Posts
Welcome from the Northwoods of MN.

Every time I get a new toy it comes with it's own learning curve. After driving our current car for three years I found out by accident that it had a digital speed read out in the instrument cluster as well as the regular speedometer! :???:
 
1 - 8 of 8 Posts
Top