Taurus Firearm Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,268 Posts
Discussion Starter #1
Just been to the range today, shot about 150 rounds through my 3rd Generation MilPro PT-111 9mm. I had a lot of problems with the slide not holding open after the last round, this hasn't happened before (have about 1200 rounds total through it). It happened mostly with just one magazine but also a bit with the other. I usually have the mags disassembled and cleaned every time after I shoot, and I blast out the pistol with Gun Scrubber. So everything was clean when I went to the range, what happened? Both magazines fed perfectly though, no flaws, just the slide hold.

On a side note, I had one failed primer today (Winchester White box FMJ's, happened once before with the same ammo). I tried the "double-strike" feature of the Taurus several times but it did not fire. I ejected the round and rechambered it and then it fired on the first try. Never had any trouble with any other brand.
 

·
Registered
Joined
·
3,501 Posts
Yeah, the mag follower has to come up far enough and compress the slide lock spring enough to get the slide lock to engage. So, we keep the mags clean and the slide lock spring lubed. I've about 1300 rounds through mine. I'll be watching that. Thanks.
 

·
Registered
Joined
·
29,846 Posts
Could be dirt/burnt gun powder fouling, a weak magazine spring, a worn follower, or all the above.

So far mine are holding up pretty good, I've got over 3,000 rds. through the blued PT111 and over 2,000 rds. through it's SS brother.

However, I've got half dozen or more magazines I keep rotated through them.
 
1 - 3 of 3 Posts
Top