Taurus Firearm Forum banner

1 - 20 of 85 Posts

·
Registered
Joined
·
89 Posts
Thank you. If I can add, the smaller spring is cut on one end, making it a bit rough on the guide rod.. Al at lakeside suggested putting that cut end on the part of the rod that doesn't move.
 

·
Registered
Joined
·
355 Posts
The official instructional video on the Lakeline recoil assembly.
https://lakelinellc.com
Thank you Armijager. I received my assembly yesterday. Your video confirmed I put it together properly.
I have not applied Locktight yet as I have a couple issues.

First, the large spring is actually moving around the outside of the guide rod screw when it is removed from the gun. And then I can't get it back in the slide. Al suggested squeezing down the diameter of the spring a bit so that it catches on the little lip of the screw.

Second issue is that I can lock the slide back if I have an empty mag in the gun. But if there is no mag inserted, I can't rack the slide back far enough to engage the slide release to lock it open. Any suggestions? Thanks and have a blessed morning at church..
 

·
Banned
Joined
·
82 Posts
For your second issue do an easy test with the assembly. Take the assembly out the gun. Hold the outer sleeve and compress the smaller spring until the two spring flanges touch. See first pic. If assembly looks like the second pic when fully depressed you have a problem.
 

Attachments

·
Registered
Joined
·
355 Posts
For your second issue do an easy test with the assembly. Take the assembly out the gun. Hold the outer sleeve and compress the smaller spring until the two spring flanges touch. See first pic. If assembly looks like the second pic when fully depressed you have a problem.
Thanks for the info. Just checked and that is okay. Small spring compresses all the way down and the two flanges touch. Must be something else.
 

·
Registered
Joined
·
1,565 Posts
Discussion Starter · #18 · (Edited)
Let's play process of elimination. Take it all apart. Switch the small inner spring with the stock spring. Put it all together. Check everything. If it works, the spring is the problem. If it still isn't right, switch out the larger outer spring and check everything. The last test is switch the metal sleeve out with the original stock sleeve.
 

·
Registered
Joined
·
1,565 Posts
Discussion Starter · #19 ·
One more test, take it all apart and put back the outer spring the other way. Maybe one end isn't milled quite right.
 

·
Registered
Joined
·
1,565 Posts
Discussion Starter · #20 ·
Make sure when you put the inner spring into the sleeve, it goes all the way to the end, if not, try it the other way. If the inner spring is clipped at one end, make sure that open end is on the outside against the flange that rests against the barell lug. I hope that makes sense.
 
1 - 20 of 85 Posts
Top