Taurus Firearm Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I NEED HELP
I just got my Taurus Millennium Pro PT145 and I was field striping it and i was putting the slide on and it got half way back on and it stoped and will not go all the way back or come back off the frame...​
 

·
Super Moderator
Joined
·
35,549 Posts
That's never happened to me with my PT 145. The safety is off correct and no magazine is in the grip?

Maybe try pulling the trigger like you did when you disassembled it the first time and yanking on the slide to remove it, keeping the pistol upright when you do so.
 

·
Registered
Joined
·
101 Posts
That happened to me with my pt745, except it happened when I was taking it down. Long story short, sent it back to Taurus for repair. Took 5 weeks, anyway. You're not the only one to post the problem, tho. I think it may have something to do with the recoil spring hanging up, but I'm really not sure. You know, it would really be nice if someone associated with Taurus would publish a fix. Would save a lot of trouble. I can't believe it hasn't happened to other Milpro pistols.
 

·
Premium Member
Joined
·
16,956 Posts
Mine has done that before, gotta screw around pushing and pulling some but not pulling the trigger while reassembling is the cause....

1.1 USA.gif
 

·
Registered
Joined
·
2,109 Posts
Funny, but I'd forgotten about that happening to me during first reassembly. I corrected it and don't remember how. That was 4 years ago and it hasn't happened again.

Evidently a good break-in period was all I needed. It's never failed me in any other way since.
 

·
Registered
Joined
·
10,439 Posts
I NEED HELP
I just got my Taurus Millennium Pro PT145 and I was field striping it and i was putting the slide on and it got half way back on and it stoped and will not go all the way back or come back off the frame...​
Without violating your privacy and security, in what state or area are you located? Maybe one of us PT 145 aficionados could meet you somewhere and remedy your situation.
 

·
Registered
Joined
·
306 Posts
I have had problems like that early on when I bought mine. I was able to get the slide off with some elbow grease.

I finally decided to use some gun grease liberally on the rails after cleaning. I havent had any problems for a while.
 

·
Registered
Joined
·
191 Posts
Just happened to me yesterday. Just started a thread in the Millenium forum.

Wanted to clean it up before it's 1st trip to the range. Followed the take down instructions to the T and as I slid the slide forward, it locked solid on me. I was really hoping to not ever have to deal with Taurus CS.
 

·
Super Moderator
Joined
·
19,641 Posts
If it locks on ya during disassembly (while pulling the slide forward) make sure to pull the trigger back into the forward (resting) position and it should release. I have never pulled the trigger when reassembling - just slides right back on. If repetitive lockup is a problem - apply liberal grease as mentioned and go shoot the hell out of it to loosen up the rails. I only experience a little resistance when slides dry or hasn't been shot in a while but usually comes right apart after a range session.
 

·
Registered
Joined
·
59 Posts
Like the others have said, just keep working it! Take it off and on and play with different trigger positions including have some hand pressure on the slide TOWARD the trigger and the PULL the trigger, that's fixed mine before.
 
1 - 10 of 10 Posts
Top