Taurus Firearm Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
This is my SECOND PT145. I had the previous one for a couple years as my daily CCW.

Just bought a new Gen 3 PT145 today. I haven't fired it yet, just got it home to field strip it and clean it. All went well until reassembly. I can't get the slide all the way to the rear, only until there is about half an inch of rear frame showing. I don't think they've changed the procedure since my version.. I read the manual a few times...no help.

What am I missing here? Anyone?
 

·
TaurusArmed.net Forum Founder
Joined
·
6,541 Posts
I had the same problem with mine. I don't remember what I did, but I know it envolved a flashlight and a screwdriver. I can't remember if it wsa through the handle or between the slide and the frame in the back.

Did you try squeezing the trigger too?
 

·
TaurusArmed.net Forum Founder
Joined
·
6,541 Posts
Come to think about it ... I think I took the barrel out of the slide and tried it again. Then after that it worked. ???
 

·
TaurusArmed.net Forum Founder
Joined
·
6,541 Posts
What about holding the trigger while putting the slide onto the frame and on back?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
Well, you can't squeeze the trigger initially, part of that mechanism protrudes above the slide rail. Once its over the first inch of slide rail, then I can squeeze the trigger, but it still won't go all the way back. I can still see the tail of the extractor. It's defintaley hitting something solid. Even with the barrel and guide rod/spring out, I cannot get the slide onto the frame all the way.

It shouldn't be this difficult. I owned one of these for over two years! :mad:
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
Okay. Thanks for the quick responses you guys.

I finally got her back together. I noticed in the manual an advice section about pushin down on the barrel hood to get the slide back. I tried that, but it didn't work until i actuated the trigger while doing it. Weird. My old PT145 didn't do this. But, at least now I know.
 

·
TaurusArmed.net Forum Founder
Joined
·
6,541 Posts
Glad to hear you got it fixed! I knew it would be something simple.

Welcome to the site BTW. :)
 

·
Premium Member
Joined
·
785 Posts
I'm trying to put your two posts together... was the magazine in the gun will trying to reassembly it? If so, the mag was pushing up slide release which would have created problems getting slide back on... and in doing so may have damaged the mag which might account for having it eject while shooting?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #10 ·
No, no. No magazine inserted during reassembly. The manual even mentions pushing down on the barrel hood to prevent the slide and barrel from sticking together. That was the problem. Just to be sure, I field stripped it again, and reassembled it like ten more times with no issues. I never had to use the pushing technique again. Strange - but glad its happy to go together now. :D
 

·
TaurusArmed.net Forum Founder
Joined
·
6,541 Posts
That kinda coincides with my one time incident and it never happening again. Wierd for sure.
 
1 - 11 of 11 Posts
Top