Taurus Firearm Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
in 40 S&W, having some problems with the buffer spring working it's way out the front of the slide when shooting the Speer Gold Dot 165's, hapens about every 15th round or so, I have no problems with my XD shooting the same ammo, any Ideas? Thanks, Les
 

·
Registered
Joined
·
6,761 Posts
There is no spec for a +P 40 S&W round and I'm not aware of any manufacturer loading beyond spec. I take that back, yes there is but the case is marked 10mm.

I'm wondering if there is an assembly or other mechanical issue here. Yes, the 165gr GD is likely a hot load but the spring should be staying in place regardless.

Could you provide some more details of what is happening?

Steelheart
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
It is like the spring is coiling out like you would screw a bolt in, I have to turn it like a bot to get the whole recoil spring assy out. Only does it with the 165 Speer Gold Dots, my light loads and WWB 180's don't do it. And no, not a +P round. Les
 

·
Registered
Joined
·
625 Posts
Call taurus, give them your SN and ask them to send you a replacement spring. If this does not help, then consider just staying away from the Gold Dots. There are other ammo that are as effective for self defence. I use the Gold Dot ammo with my PT145 and have never had an issue, but the .40 is a little faster bullet, and your gun just may not like it.

Todd
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
Gonna have to send it back to them, they think the slide may be out of spec, I have had this for less than a Month. :( Les
 
1 - 6 of 6 Posts
Top