Taurus Firearm Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
Anybody experiencing this?
My 845 with approx 1000 to 2000 round fired is on its 3rd extractor.
Both extractor having chipped in the same spot.
Weak design? How can I improve this?

I noticed if I used hot loads like 4.3 powder charge it would broke. But if I use the standard reload charge of 4.0 she would fail to cycle and the spent casing would remain in the chamber. 1000 round would be broken in right?

Any ideas?
 

Attachments

·
Registered
Joined
·
36,032 Posts
3 extractors in 2000 rounds is a bunch, way ,way out of the norm!
ahh yea way past break in!
I have no idea of what to suggest to correct this except replacing the extractor, maybe have a gunsmith to check it out?
a HOT as you describe it doesn't normally show itself in this fashion , normally a OVER SAAMI loading will show up in the brass case first.
 

·
Registered
Joined
·
104 Posts
Discussion Starter #3
I did have the gunsmith checked it on the 3rd extractor. He could not find anything wrong. Only pattern I see if when I shoot those 4.3 - 4.2 powder charged loads. Not only that my trigger spring broke somewhere between the 2 extractors. I have bought extra extractor and spring just in case it happens again.

Lastly, I just noticed that my firing pin block protrudes to a point where it rubs against the hammer.

Anybody out there who has an 800 series experience any of these and how it was rectified?
 

Attachments

1 - 3 of 3 Posts
Top