Taurus Firearm Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
MY 24/7 PRO C DS WON'T ALWAYS FIRE ON THE FIRST STRIKE AFTER USING THE DECOCKER. I SENT IT IN TO TAURUS 3 TIMES AND FINALLY THEY REPLACED IT.THOUGHT EVERYTHING WAS FINE WITH THE NEW ONE,BUT IT DIDN'T LAST LONG.SOMETIMES IT FIRES ONTHE FIRST HIT ,SOMETIMES IT TAKES 2OR 3 HITS.SHOULDN'T IT FIRE ON THE FIRST STRIKE EVERY TIME AFTER DECOCKING ,TAKE THE SAFTY OFF AND PULL THE TRIGGER? i WOULD LIKE TO BE ABLE TO USE THE DECOCKER WHEN I CARRY,BUT I DON'T TRUST IT.
 

·
Registered
Joined
·
3,223 Posts
I don't blame you!!! wish I could help you but I'm sure someone will come along that can, this is a great forum....
 

·
Registered
Joined
·
1,363 Posts
Yes there is no reason it should not fire on the first strike after decocking unless the mechanism is malfunctioning. All my semi-autos with decockers fire after decocking. If the device is not working correctly there is always a chance that if you have one in the chamber decocked and somehow the trigger gets pulled it could fail and also discharge. Send it back that firearm is not safe if the decocker is malfunctioning.
 

·
Registered
Joined
·
40 Posts
at least they replaced it.
 

·
Registered
Joined
·
258 Posts
BOB 345
Try a couple of other things before sending it back. 1) Take the slide off and hose it down real good with Gunscubber or non-clorinated brake parts cleaner. Make sure you get into every nook and cranny. Always wear eye protection while performing this task. Wipe away excess. 2) spray cleaned slide with Sea Foam Deep Creep (auto parts store) getting into every nook and cranny. Wipe away excess and reassemble. Then return to the range and try it again. Also, try a different brand of ammo. Sellier & Bellot or Federal, you could be experiencing hard primers or primers that have been set too deep.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
scalphunter, I tried your suggestions. No change,but when I cleaned it, I blew some more of the deep creep out with compressed air. I'll try it again this weekend. It just really feels like it's that "second strike" trigger set-up.Seems like it does decock,but it does'nt always connect when you pull the trigger. It runs great untill you decock it.Just seems wierd that I have 2 24/7 in a row that have the same problem. My P345 decocker works fine.Thanks for your and everyones replies.
 

·
Registered
Joined
·
3,501 Posts
I'd be really brave and take the striker out and clean the channel and the spring. I'd puff a tiny bit of powdered graphite in there and assemble it again. The other guys here have already given good ideas.

If doing all these things to cleean and clear the mechanism stll doesn't work it's back to Miami again. That decocker must work every time.

My .02
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
Remington,federal winchester and hand loads with rem primers.Took the trigger assy. apart and tried it again. Out of 70, 4 did not go bang after decocking.This time i thought to check the cartrage after.All 4 had light primer hits! So it is time to tear apart the slide and check the firing pin system as you suggested.Wish me luck.keep you posted. thanks.
 

·
Registered
Joined
·
35 Posts
I can't believe that happened, I guess the semi-auto handguns are faulty, but I promise you, not one... no not one of my revolvers every had an issue... one up for the revolver boys!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
djcov1969, I have not had a lot of luck w/ my Taurus auto hand guns, my pt1911 had to go back a couple of times too. I just really want to trust them, but I can't.Had an ultra lite 38 snub that always wanted to lock up on me. My 605,607 and mod 44 have been good to me. Have completly disassembled my 24/7 and cleaned, lubed and checked it over. still get light hits that don/t fire 4-5 times out of a box of 50,after decocking.Hit them 2&3 times , no bang. But if I re-chamber them and don't decock, they fire fine. Firing pin just seems to loose some of it's "poop" after decock. I give up, either never decock it or send it in. After my other times of sending my guns to taurus for repair, I don't trust they can even figure it out. Thanks to everyone that replied and tried to help me out.Glad that I joined, Seems to be some "good folk"here.Thanks again.


i
 

·
Premium Member
Joined
·
15,931 Posts
I sure have not noticed that problem with my 24/7, but I only have a couple hundred rds thru it. I used decock during a class, and remember no problems with that, but I did have extractor, ejection problems, which were fixed by a trip back to Miami.
 
1 - 12 of 12 Posts
Top