Taurus Firearm Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
First time posting on here and glad to be on here with other Taurus lovers. Just bought a 24/7 G2 and Millenium G2 saturday. Shot both same day and had no problems. Changed the back strap on the G2 today and went to go shoot and get a feel for it. For some reason its not catching the firing pin everytime and some times it wont release? Also the slide release is stuck and wont move down. I had the slide off earlier with no problems? It still fires but stays in SA mode after the first shot. I have my Taurus slim in service right now and really dont want to send this one in wait 4-6 weeks to get it back so hopefully you guys might have a solution. Thanks.
 

·
Registered
Joined
·
6,986 Posts
Yep, it's in DA on the 1st shot, SA on the following shots unless you have a misfire then the trigger will switch to DA for 2nd strike.

If you have not removed the firing pin assembly to clean it and the firing channel, you need to do it.




Welcome from Texas!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I know it's DA first then SA but I was under the assumption that if you release the trigger all the way it resets to DA? I can't pull down the slide release to get the slide off. It acts like something is stopping it.
 

·
Registered
Joined
·
526 Posts
I know it's DA first then SA but I was under the assumption that if you release the trigger all the way it resets to DA? I can't pull down the slide release to get the slide off. It acts like something is stopping it.

It only reverts to DA if you push the decocker or a rounds primer fails.
As for the slide, when you pull the slide back and pull down the takedown levers you need to pull the trigger to release the slide.
 

·
Registered
Joined
·
2,195 Posts
I know it's DA first then SA but I was under the assumption that if you release the trigger all the way it resets to DA? I can't pull down the slide release to get the slide off. It acts like something is stopping it.
first time i removed the slide, i had the same problem. you have to pull down the levers on both sides at the same time and them pull the trigger (just like rawmade said).
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Ah, yeah I thought it went DA with the trigger completely released. I like that it stays SA then. I pull both tabs evenly and it won't budge. I had the slide off Monday but now it won't pull down for nothing.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top