TCP magazine issue
Results 1 to 10 of 10
Like Tree4Likes
  • 1 Post By Taurustrust
  • 1 Post By Taurustrust
  • 1 Post By Taurustrust
  • 1 Post By hughewil

Thread: TCP magazine issue

  1. #1
    Junior Member
    Member #
    51186
    Join Date
    Jul 2016
    Posts
    29
    Liked
    8 times

    TCP magazine issue

    Hi,
    I just got back from the range and had a rough day to say the least. Prior to today, I had two prior flawless range visits. I will number my issues with the hopes responses can help correct them more easily.

    1. I have 4 magazines for my gun. While shooting, one of them fell out halfway through. This mag no longer will click into place in the gun. All my other mags work and stay in the gun. Is there a known fix for this?

    2. While shooting off a different magazine, the same magazine locked the slide back while still having one round in the magazine left to chamber. Any know fix for this issue?

    3. I have been having trouble feeding the first round into the chamber. It keeps getting jammed now.

    Ammo used was Web fmj round nose, Web fmj flat nose, wwb jhp. Same as I have always used. Gun was cleaned prior to the range trip. I have a D series bitone TCP. Thanks for any help.

    Sent from my Nexus 6P using Tapatalk

  2. #2
    Member
    Member #
    49761
    Join Date
    Jun 2016
    Posts
    34
    Liked
    23 times
    When you clean the gun, do you also clean the magazines? They get a lot of soot from dirty ammo.
    Reeko likes this.

  3. #3
    Junior Member
    Member #
    51186
    Join Date
    Jul 2016
    Posts
    29
    Liked
    8 times
    Quote Originally Posted by Taurustrust View Post
    When you clean the gun, do you also clean the magazines? They get a lot of soot from dirty ammo.
    I wipe them down. How do you clean the mags?

    Sent from my Nexus 6P using Tapatalk

  4. Remove Advertisements
    TaurusArmed.net
    Advertisements
     

  5. #4
    Member
    Member #
    49761
    Join Date
    Jun 2016
    Posts
    34
    Liked
    23 times
    Use youtube for a video. Just search "cleaning a magazine". A picture tells a thousand stories.
    Reeko likes this.

  6. #5
    Member
    Member #
    49761
    Join Date
    Jun 2016
    Posts
    34
    Liked
    23 times
    Also clean and polish the feed ramp, if you haven't already.
    Reeko likes this.

  7. #6
    Senior Member
    Member #
    49307
    Join Date
    Apr 2016
    Posts
    724
    Liked
    1151 times
    Reeko likes this.

  8. #7
    Junior Member
    Member #
    51186
    Join Date
    Jul 2016
    Posts
    29
    Liked
    8 times
    Thanks. I will take a look

    Sent from my Nexus 6P using Tapatalk

  9. #8
    Member
    Member #
    49761
    Join Date
    Jun 2016
    Posts
    34
    Liked
    23 times
    I am sorry Reeko, I forgot about this issue in the video. It sure could be if shooting FMJ. I have had good luck with my series F TCP.

  10. #9
    Member
    Member #
    48468
    Join Date
    Feb 2016
    Location
    Memphis
    Posts
    56
    Liked
    20 times

    Cool Old TCP Fix

    Quote Originally Posted by Reeko View Post

    2. While shooting off a different magazine, the same magazine locked the slide back while still having one round in the magazine left to chamber. Any know fix for this issue?

    3. I have been having trouble feeding the first round into the chamber. It keeps getting jammed now.

    I have a D series bitone TCP. Thanks for any help.
    I have a F series TCP. On my TCP F series never had a feed problem never had a mag drop. I read that pushing in the mag without pushing the mag release can cause damage.
    FYI
    After I insert a mag with only 5 in the mag I press in the mag and insure the mag release is fully engaged.

    On that vid the factory has reworked the feed problems.
    Also
    I have found some clone mags are junk and used mags may have been bent or reformed to improve feed problems in the older TCPs
    Again
    F series TCP has been fixed by factory (see photo)
    Attached Images Attached Images  
    Last edited by Memphis3; 07-06-2016 at 03:20 PM.

  11. #10
    Junior Member
    Member #
    51186
    Join Date
    Jul 2016
    Posts
    29
    Liked
    8 times
    Quote Originally Posted by Memphis3 View Post
    I have a F series TCP

    On that vid the factory has reworked the feed problems. I have also found some clone mags are junk and used mags may have been bent or reformed to improve feed problems in the older TCPs
    Again
    F series TCP has been fixed by factory (see photo)
    Doubt they would replace me again, I will give it a go one more time at the range. I called and they are replacing the magazine that won't stay mounted, so that's a plus. Hopefully, it will fire well the next time I go.

    Sent from my Nexus 6P using Tapatalk

 

 

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. im having a magazine issue with my tcp 380
    By packersfan036 in forum The 700's
    Replies: 1
    Last Post: 08-16-2014, 07:35 AM
  2. Taurus 738 TCP magazine issue
    By cobbler1262 in forum The 700's
    Replies: 9
    Last Post: 02-04-2014, 10:28 PM
  3. TCP Magazine Issue
    By Jutte in forum The 700's
    Replies: 13
    Last Post: 01-16-2014, 09:50 PM
  4. TCP Magazine Release Issue - Magizine Drop While Concealed
    By Hotrod620 in forum Taurus Product Problems
    Replies: 15
    Last Post: 04-09-2013, 06:23 PM
  5. TCP magazine issue
    By handyflyer in forum The 700's
    Replies: 3
    Last Post: 01-17-2013, 06:34 PM