First 50 rounds in my new TCP.
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31
Like Tree19Likes

Thread: First 50 rounds in my new TCP.

  1. #1
    Junior Member
    Member #
    55690
    Join Date
    Nov 2016
    Location
    North Carolina
    Posts
    10
    Liked
    4 times

    First 50 rounds in my new TCP.

    The first magazine was a hoot. Accuracy was good. Function was perfect.

    Then . . . the slide locked back, after almost every shot! A total of 50 rounds fired. The ammo was PMC, 90 grain, FMJ. Also, most of the fired cases were ejected over my head, directly behind me. Six or eight did eject to my right. Several times in the last 3 magazines, I had to bump the slide, for the slide too fully return to battery.

    After a good cleaning, maybe 100% function will return? I'm concerned about the slide locking back, with rounds still in the magazine.

  2. #2
    Senior Member
    Member #
    48273
    Join Date
    Jan 2016
    Location
    Valdosta, Ga
    Posts
    117
    Liked
    99 times
    Did the pistol come with 2 magazines? If so, did it do it with both mags?

  3. #3
    Senior Member
    Member #
    39495
    Join Date
    Nov 2013
    Location
    Bay City, MI
    Posts
    497
    Liked
    476 times
    doubt it^^^

    Great, I better go shoot my "1D" serial gun now and see what mine does...dadgum it...
    "Original (first gen) PT-92" owner
    previous owner of PT111G2 & Gen 1 PT111 9mm's & "D" series TCP 738

    GO NOLES!!!

  4. Remove Advertisements
    TaurusArmed.net
    Advertisements
     

  5. #4
    Junior Member
    Member #
    55690
    Join Date
    Nov 2016
    Location
    North Carolina
    Posts
    10
    Liked
    4 times
    Quote Originally Posted by Car_Doc View Post
    Did the pistol come with 2 magazines? If so, did it do it with both mags?
    The pistol came with only one magazine.

  6. #5
    Junior Member
    Member #
    45359
    Join Date
    May 2015
    Location
    Cape Fear Area, North Carolina
    Posts
    27
    Liked
    47 times
    I would closely inspect the rails on the slide and the body and make sure there is no damage or cracks. Check the magazine as well.

    If you see nothing, I have read in many cases a change of ammo brand helps. I'm not bashing PMC. I just read about people changing ammo and their FTF or FTE problems go away. Some guns don't like certain ammo.

    What series is your 738?
    Last edited by ArmedDefender; 12-02-2016 at 10:30 PM.
    Circuit Judge (2), 738 TCP, Rossi .38 Special

  7. #6
    Junior Member
    Member #
    55690
    Join Date
    Nov 2016
    Location
    North Carolina
    Posts
    10
    Liked
    4 times
    Quote Originally Posted by ArmedDefender View Post
    What series is your 738?
    There is a D in my serial number. It's 1D0xxxxxx. Purchased from Sports Academy, on 11/28/2016.

  8. #7
    Junior Member
    Member #
    45359
    Join Date
    May 2015
    Location
    Cape Fear Area, North Carolina
    Posts
    27
    Liked
    47 times
    Quote Originally Posted by forgottenone View Post
    There is a D in my serial number. It's 1D0xxxxxx. Purchased from Sports Academy, on 11/28/2016.
    Same as mine. I can only suggest trying different ammo. I am shooting Federal with no problems.
    Circuit Judge (2), 738 TCP, Rossi .38 Special

  9. #8
    Senior Member
    Member #
    43407
    Join Date
    Oct 2014
    Location
    South Carolina
    Posts
    601
    Liked
    696 times
    Same thing happened to mine.. Welcome to T.A.. I stayed here and listened to the other older members of the forum here. I never shipped mine back, and it's working like it should.
    I know right off the its hard to see that stuff happening. Give me some time to write up some issues that "mine" had.. and some other things to look at,
    GhostHorse likes this.
    RYRYRYRY
    "Now is the time for all good men to come to the aid of their country"

  10. #9
    Senior Member
    Member #
    43407
    Join Date
    Oct 2014
    Location
    South Carolina
    Posts
    601
    Liked
    696 times
    It could be a few things. Here is somethings that I learned along the way..

    What ever you do below, very much "clean it" and also before use a gun oil.. even cheap REM OIL and make the inside "look wet" right before going to the range.

    People have told me that you need to shoot more then 50 rounds, to "break" the gun in.
    What I have done is the following and again, this many "not" be the same as your issue, and I'm not saying to do any of this as it may voild your warranty, but this worked "for me". I'll also put some other things to check in the post.

    I buffed \ polished the feed ramp, there is many ways to do this and recently did this again using a generic dremel rotary tool. Shooting the gun also will make your feed ramp smooth, but a lot of guys will tell you to do this. I'll post a video below in regards to this. I also buffed / polished the cocking rail on the slide and the outside barrel.

    I took off (sanded) some of the material ( and we are talking millimeters) off of the red follower on the magazine itself, the part that the slide tab "rests" on. There was a bit of material on this. I also can tell you that even if you bought a new magazine it also may have the same issue or an issue with the feed lips of the magazine.

    After shooting more, the issue started to occur less and about 300 rounds, "for me" the gun is solid with the original one magazine. If I shoot six out, the slide locks back, no issues. Also to note, I shot PMC Bronze FMJ like you had, and no issues other then being a bit on the "dirty side". Some guys will tell you, even afterwards, your gun may like different ammo then another. I also have an "E" series, no "D" like you have.

    Here is some other things to check:

    The slide tab "may" need to be rounded more:


    Some people claim this works, some say don't do it:


    Here is some other polishing and also the slide tab again:


    I hope you stay around, I'm glad that I did.
    Last edited by HappyTom; 12-03-2016 at 02:53 PM.
    RYRYRYRY
    "Now is the time for all good men to come to the aid of their country"

  11. #10
    Junior Member
    Member #
    55690
    Join Date
    Nov 2016
    Location
    North Carolina
    Posts
    10
    Liked
    4 times
    HappyTom, thanks for sharing your information and videos. I'm definitely going to "stay around". Heck, I'm a veteran Kel-Tec owner. I think Kel-Tec owners originated the "Fluff & Buff" treatment. I've never had a Kel-Tec that was as finicky as this TCP, right off the bat. I was hoping that Taurus had worked the kinks out by now. I'm optimistic that the TCP kinks can be banished. I really like the feel of this little pocket pistol, over the Kel-Tec and Ruger offerings. This forum is a tremendous resource for Taurus owners.
    ArmedDefender and HappyTom like this.

 

 
Page 1 of 4 123 ... LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. What .380 rounds have you used in your TCP?
    By TMartinez in forum Factory Loads
    Replies: 8
    Last Post: 01-20-2013, 02:51 PM
  2. Replies: 22
    Last Post: 05-23-2010, 11:09 AM
  3. Replies: 0
    Last Post: 03-31-2010, 01:20 PM
  4. 500 Rounds through my TCP
    By boykinhntr in forum The 700's
    Replies: 7
    Last Post: 02-12-2010, 04:26 AM